2003-04 Mach 1 Registry Owners Club  

Best Mustang Parts

Go Back   2003-04 Mach 1 Registry Owners Club > "GO" Discussions > Engine & Drivetrain (Including trans & rear axles)

Reply
 
Thread Tools Display Modes
Old 04-04-2019, 02:36 PM   #1
HamMach1
A.D.D. FTL
 
HamMach1's Avatar
 
Join Date: Oct 2006
Location: Jacksonville, FL
Posts: 3,009
Car died while driving on highway and sputters after a couple hot starts

First occurrence in December:
  • Driving 70 on highway
  • Suddenly lost throttle response so I pulled over as the engine was sputtering and making a sort of "popping" exhaust sound beneath me before it eventually died
  • It would start back up but then immediately fall to a sputter and die again and threw a code
  • By the time the tow truck came about an hour later, the car started back up and idled just fine
  • Towed to dealership anyway and had fuel filter replaced, the fuel system serviced, and the code cleared (something about fuel I don't recall)

Second occurrence in February:
  • Drove 8 miles from work to home and parked the car
  • About 30 minute later I head back out for 5 miles and park the car
  • About 15-20 minutes later I leave store, start it, and as it lowers to normal idle it begins to sputter a bit and acts like it wants to die
  • I turn it off and let it sit for maybe 10 minutes and it starts up and runs fine

Third occurrence in February a couple of days later:
  • Drove to the airport about 20 miles and parked the car
  • About 30-45 minutes later I start the car to leave. The engine lowers to idle speed and proceeds to sputter/pop/sound like it wants to die but doesn't.
  • I turn it off and let it sit for maybe 10-20 minutes and it starts up and runs fine

I took it to the dealership again and of course they couldn't duplicate the issue so I had them replace the pump anyway. Worst case scenario is yay I have a new fuel pump.

It still does this after:
  • Fuel filter replaced
  • Fuel system cleaning
  • Fuel pump replaced
  • MAF sensor cleaned
  • Air filter replaced
  • Spark plugs replaced early last year

Ideas? The Mach has a 120,000 on it for what it's worth. I'm not sure if that sounds like an IAC or something fuel related like injectors or coils. Or maybe I should just throw all three at it.

The bolded is the long story short

Last edited by HamMach1; 04-04-2019 at 02:53 PM.
HamMach1 is offline   Reply With Quote
Old 04-04-2019, 03:55 PM   #2
fastlane
Registered User
 
Join Date: Mar 2011
Location: Fort Worth, TX
Posts: 207
Re: Car died while driving on highway and sputters after a couple hot starts

Need to know what is the code that is presented. The FPRS could be the culprit.
fastlane is offline   Reply With Quote
Old 04-04-2019, 04:02 PM   #3
ab_mach1
Lorraine's driver
 
ab_mach1's Avatar
 
Join Date: Apr 2012
Location: Indianapolis/Brownsburg, IN
Posts: 2,201
Re: Car died while driving on highway and sputters after a couple hot starts

Was the first time when this happened (Dec) the only time it threw a code? Also, what exactly was that code?
__________________
  • Azure Blue 04 Mach 1
  • SCT X3 with LaSota Racing tune
  • Borla Stingers w/JBA off road H pipe
  • MGW short shifter w/comfort handle
  • Eibach Sportlines w/Koni STR.T's and Maximum Motorsports CC plates
ab_mach1 is offline   Reply With Quote
Old 04-17-2019, 09:30 PM   #4
Mach351
Psycho Dog is Psycho
 
Mach351's Avatar
 
Join Date: Sep 2008
Location: Lewisville, TX
Posts: 1,924
Re: Car died while driving on highway and sputters after a couple hot starts

I feel like we've been left in suspense here.

Do I get a prize if I say it is the throttle body/TPS and get it right?
_
Mach351 is offline   Reply With Quote
Old 04-18-2019, 08:12 AM   #5
DSG2003Mach1
700 HP Mach
 
DSG2003Mach1's Avatar
 
Join Date: Nov 2003
Location: Orlando, FL
Posts: 8,181
Re: Car died while driving on highway and sputters after a couple hot starts

based on similar posts I would suspect the FPDM (under the kick panel in the trunk on the driver's side).
__________________
03 dsg mach1 - MPR built 9.5:1 motor, D1, cams, ported intake, full exhaust, magnum t56, built rear, E85 etc...

'12 F150 FX2 Supercrew with Ecoboost daily beater
DSG2003Mach1 is offline   Reply With Quote
Old 04-18-2019, 12:44 PM   #6
jbrad88
Original Owner
 
jbrad88's Avatar
 
Join Date: Apr 2003
Location: Houston, Texas
Posts: 4,938
Re: Car died while driving on highway and sputters after a couple hot starts

Quote:
Originally Posted by DSG2003Mach1 View Post
based on similar posts I would suspect the FPDM (under the kick panel in the trunk on the driver's side).
Agreed
Possible ccrm as well
__________________
JB

03 Torch Red Mach 1

Stainless Steel Systems Adrenaline Series
18x9 - Solid Gloss Black FR5's
Nitto 555 g2 275/35r18's
MGW Shifter With Mach1 Shift Knob
4.10's & 31 spline Mosers and 31 Spline Posi
(installed by Pyle Bros)
Steeda Sport Springs Tokiko Illuminas
J@M weight Jacker LCA's
J@M Rear UCA's
J@M Braided steel brake lines
jbrad88 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:33 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
(c) 2002-2013 Mach1Registry.com

<