2003-04 Mach 1 Registry Owners Club  

Best Mustang Parts

Go Back   2003-04 Mach 1 Registry Owners Club > "GO" Discussions > Electrical System

Reply
 
Thread Tools Display Modes
Old 09-22-2017, 08:36 PM   #1
stangmach104
Registered User
 
Join Date: Jun 2005
Location: Minneapolis, MN
Posts: 117
Car started shutting off while driving

Hello, just started having an electrical and/or fuel issue on my 04mach1. I have a return set up and tuned on e85. Anyways the other day I was getting on the highway as I felt the car lose power for about a second. Did it 3-4 times and every time when I'd check the fuel pressure gauge the problem had already passed. Well a few more miles down the road it shut off while doing 70mph. Pulled over and it started right back up and didn't have a problem for 150 miles. Today was the first time I drove it since, about 5 days inbetween and after 11 miles it starts doing it again but now it shut off 4 times. Each time starting right back up and less than a minute before each one I could feel it jerk like it lost all its power. I don't even know where to start. Changed out my fuel filter right away because I know e85 cleans out everything. Any ideas? No check engine lights at all.
__________________
#6690
Forged Short Block built by myself, Procharger D1SC
Stage 2 s/c cams, Custom o/r x-pipe
Flowmaster Cat Back, Mid-Length Headers
2 Walbro 400lph pumps on return style system
95# Fuel Injectors
10% O/D Balancer, AFM Power Pipe
630 rwhp 531 rwtq
stangmach104 is offline   Reply With Quote
Old 09-22-2017, 10:26 PM   #2
DSG2003Mach1
700 HP Mach
 
DSG2003Mach1's Avatar
 
Join Date: Nov 2003
Location: Orlando, FL
Posts: 7,989
Re: Car started shutting off while driving

id be trying to keep an eagle eye on that pressure gauge or get a passenger to do it. It could be a fuel pressure issue, could be a tune issue too I suppose
__________________
03 dsg mach1 - MPR built 9.5:1 motor, D1, cams, ported intake, full exhaust, magnum t56, built rear, E85 etc...

'12 F150 FX2 Supercrew with Ecoboost daily beater
DSG2003Mach1 is offline   Reply With Quote
Old 09-22-2017, 11:12 PM   #3
stangmach104
Registered User
 
Join Date: Jun 2005
Location: Minneapolis, MN
Posts: 117
Re: Car started shutting off while driving

Just drove 20 miles and no issues. Been watching fuel pressure but like I said no issues this time. I have 2 pumps on a return line both running at 100% duty cycle because I don't have an fpdm obviously so if one pump is failing the other should be able to keep up. I run it at 40 psi
__________________
#6690
Forged Short Block built by myself, Procharger D1SC
Stage 2 s/c cams, Custom o/r x-pipe
Flowmaster Cat Back, Mid-Length Headers
2 Walbro 400lph pumps on return style system
95# Fuel Injectors
10% O/D Balancer, AFM Power Pipe
630 rwhp 531 rwtq
stangmach104 is offline   Reply With Quote
Old 09-30-2017, 04:26 PM   #4
Oxford04auto
Registered User
 
Join Date: Jul 2016
Location: Nampa,idaho
Posts: 43
Re: Car started shutting off while driving

I had the same issue with my fox...the fuel pump would get hot and shut down...i figured this out because it happened as I went to the Gas Station....it died and I pushed it in....got gas and the car fired right up....i changed the pump to much larger in tank pump and it's never did it again.....
Oxford04auto is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:18 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
(c) 2002-2013 Mach1Registry.com

<