2003-04 Mach 1 Registry Owners Club  

Best Mustang Parts

Go Back   2003-04 Mach 1 Registry Owners Club > "GO" Discussions > Engine & Drivetrain (Including trans & rear axles)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-09-2017, 08:18 PM   #1
rsnider
Registered User
 
rsnider's Avatar
 
Join Date: Apr 2003
Location: Phoenix, AZ
Posts: 2,336
Fails to start when outside temps over 100

I've been dealing with this dang issue for two years now. When the temperature is over 100 degrees outside the Mach won't start. If I let her sit until evening when the temps drop she will run. Except for yesterday. It was about 110 here in Phoenix and I pulled her out of the garage to do some cleaning up. About 2pm I went to pull her back inside and she cranks and spits a couple of times but won't start.
My mechanic replaced some sort of vacuum switch under the hood and the fuel module in the trunk. It's been find for six months, but I just don't drive her much in the summer.
Anyone who has had a similar issue please HELP.
rsnider is offline   Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
(c) 2002-2013 Mach1Registry.com

<