2003-04 Mach 1 Registry Owners Club  

Best Mustang Parts

Go Back   2003-04 Mach 1 Registry Owners Club > "GO" Discussions > Engine & Drivetrain (Including trans & rear axles)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-15-2017, 01:01 AM   #1
torchmac23
Registered User
 
Join Date: Feb 2012
Location: EL paso tx
Posts: 32
HELP HELP !!! Car won't start

Hoping to get some help!! I have a 03 mach and it has a fresh build on it roughly about 1500 miles. First day I got the car back from the shop while driving back home the car shut off in the middle of the road. Called the guy from shop and he showed up, when I would try to turn on the car the theft light would blink came to find that pcm fuse was blown replaced it and started back up. A few days later in the morning before work I forgot something inside the house as I came back car was dead and same issue pcm fuse blown out again. So finally about two weeks ago I made it to my drive way and it shut off on me come to find same issue blown fuse. This time I have disconnected the battery replaced the fuse but as soon as I try to turn it on it blows the fuse it cranks but doesn't turn on. I really don't want to call the guy from the shop because I know it will take months before he touches it. And before I take it into ford $$$ I want to get some feedback. Any help is appreciated and sorry if this is not the correct forum.
Thank you in advance!!'
torchmac23 is offline   Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:40 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
(c) 2002-2013 Mach1Registry.com

<