2003-04 Mach 1 Registry Owners Club  

Best Mustang Parts

Go Back   2003-04 Mach 1 Registry Owners Club > "GO" Discussions > Engine & Drivetrain (Including trans & rear axles)

Reply
 
Thread Tools Display Modes
Old 05-07-2018, 11:54 AM   #1
stangmach104
Registered User
 
Join Date: Jun 2005
Location: Minneapolis, MN
Posts: 120
Hesitation at cruising speed

Hey guys Iím having a hesitation problem. It started last year and got so bad that the car wouldnít idle for more than 19 seconds without stalling. Replaced the MAF sensor and the IAC and got it to stop stalling last fall. Took the car out for the first time this spring today and itís still hesitating at cruising speed. Doesnít do it right away but when it starts it does it every 15-20 seconds and only for about a second. Iím replacing the spark plugs and checking all the coils this week along with inspecting all the cop harnesses and injector harnesses. Anything else I should check for? Fuel filter has also been changed. Thanks for any help.
__________________
#6690
Forged Short Block built by myself, Procharger D1SC
Stage 2 s/c cams, Custom o/r x-pipe
Flowmaster Cat Back, Mid-Length Headers
2 Walbro 400lph pumps on return style system
95# Fuel Injectors
10% O/D Balancer, AFM Power Pipe
630 rwhp 531 rwtq
stangmach104 is offline   Reply With Quote
Old 05-07-2018, 12:41 PM   #2
311-420
M-112 Mach 1
 
311-420's Avatar
 
Join Date: Sep 2007
Location: +Ä◊♤$
Posts: 6,689
Re: Hesitation at cruising speed

It's probably a c.o.p.
__________________
04 Oxford White // 5spd, IUP, Eaton--452/409
311-420 is offline   Reply With Quote
Old 05-07-2018, 01:22 PM   #3
ab_mach1
Lorraine's driver
 
ab_mach1's Avatar
 
Join Date: Apr 2012
Location: Brownsburg, IN
Posts: 2,111
Re: Hesitation at cruising speed

Quote:
Originally Posted by 311-420 View Post
It's probably a c.o.p.
Agree...Mine had something very similar and the COP's were the cause. Or at least the connection to them, anyways. I had read others had used dielectric grease in the end of the boot that connects to the plug. I went and did this to mine and hesitation and the few "fish bites" i was having did not return. I think another solution would be to just buy new boots, but the dielectric grease has been working since, without replacing any of them. That's been a good 5 years ago.
__________________
  • Azure Blue 04 Mach 1
  • SCT X3 with LaSota Racing tune
  • Borla Stingers w/JBA off road H pipe
  • MGW short shifter w/comfort handle
  • Eibach Sportlines w/Koni STR.T's and Maximum Motorsports CC plates
ab_mach1 is offline   Reply With Quote
Old 05-08-2018, 08:44 AM   #4
HAEG
Heppasketties
 
HAEG's Avatar
 
Join Date: Aug 2003
Location: Mercer County, NJ
Posts: 4,404
Re: Hesitation at cruising speed

Having similar issues myself recently, going to try the dielectric grease since I didn't use any when I recently replaced the plugs. I also had a set of barely used COP's I put on the car to replace my 112,000 mile ones. I have an issue at around 2,000 rpm's with a hesitation and possible misfire. Curious what Stangmach104 will find with his car.
__________________
M1R Member #1829
2011 Shelby GT-500 Grabber Blue
W/SVT Performance Package
Born on Friday, 6-25-2010
Purchased 8-19-2010

2003 Zinc Yellow Auto I/UP (Build #8280 of 9652)
Born on Thursday, 7/17/03
Purchased 8-18-2003 first owner
Sold 8-19-2010 bought GT500
Purchased again 3-3-2017 fifth owner
Purchased for my wife to drive (but she knows I love the car)
HAEG is offline   Reply With Quote
Old 05-14-2018, 11:27 AM   #5
stangmach104
Registered User
 
Join Date: Jun 2005
Location: Minneapolis, MN
Posts: 120
Re: Hesitation at cruising speed

So I switched plugs and used dielectric grease on everything. Iíve only put 12 miles on it but so far so good. I plan on driving the car to work tomorrow and thatís 60 miles round trip so I should know for sure if that took care of it. Thanks for the info.
__________________
#6690
Forged Short Block built by myself, Procharger D1SC
Stage 2 s/c cams, Custom o/r x-pipe
Flowmaster Cat Back, Mid-Length Headers
2 Walbro 400lph pumps on return style system
95# Fuel Injectors
10% O/D Balancer, AFM Power Pipe
630 rwhp 531 rwtq
stangmach104 is offline   Reply With Quote
Old 05-14-2018, 12:28 PM   #6
01yellerCobra
Registered User
 
Join Date: Jan 2013
Location: San Diego, CA
Posts: 1,102
What brand of plugs were you running?
__________________
New Ride:
2004 Mystichrome Cobra-Accufab SBTB and plenum, Steeda 2.8" upper, Bassani X, Borla Stingers, Mcleod RXT, MGW shifter, Level 5 halfshafts, chrome FR500's, Stiffler's FIT system and DS safety loop, GT pumps, BA3000, tuned by owner
01yellerCobra is offline   Reply With Quote
Old 05-14-2018, 09:58 PM   #7
stangmach104
Registered User
 
Join Date: Jun 2005
Location: Minneapolis, MN
Posts: 120
Re: Hesitation at cruising speed

Ngk
__________________
#6690
Forged Short Block built by myself, Procharger D1SC
Stage 2 s/c cams, Custom o/r x-pipe
Flowmaster Cat Back, Mid-Length Headers
2 Walbro 400lph pumps on return style system
95# Fuel Injectors
10% O/D Balancer, AFM Power Pipe
630 rwhp 531 rwtq
stangmach104 is offline   Reply With Quote
Old 05-28-2018, 07:17 AM   #8
Colloggett
Registered User
 
Join Date: May 2007
Location: Nottingham, UK
Posts: 43
Re: Hesitation at cruising speed

I had this problem and it was a faulty coil pack. I didn't have the time to replace them one by one to identify the culprit, so I changed them all and that fixed it. They were ridiculous money from Ford, but I got a set for $90 online. It was a while ago though.

Richard.
Colloggett is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:32 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
(c) 2002-2013 Mach1Registry.com

<