2003-04 Mach 1 Registry Owners Club  

Best Mustang Parts

Go Back   2003-04 Mach 1 Registry Owners Club > "GO" Discussions > Engine & Drivetrain (Including trans & rear axles)

Reply
 
Thread Tools Display Modes
Old 10-11-2017, 09:36 PM   #1
03Shadow Grey
Registered User
 
03Shadow Grey's Avatar
 
Join Date: Feb 2016
Location: Theodore Alabama
Posts: 243
Lifter tapping noise !

I know these engines do not have lifters but that is what it sounds like.
I have read a lot of the searches on the dreaded Tick and they don't compare with what mine is doing.
It is quiet at start up and idle but when I take off in first through fifth at around 2 k and climbing under load I hear it.In all gears if I stop climbing and stay at a particular rpm its gone but if I get back on it to go, there it is. Kinda like the old lifter tap when the timing was off. I took it to the muffler shop hoping it was just an exhaust leak and they found none, Any suggestions would be much appreciated.
03Shadow Grey is offline   Reply With Quote
Old 10-11-2017, 10:06 PM   #2
01yellerCobra
Registered User
 
Join Date: Jan 2013
Location: San Diego, CA
Posts: 1,059
Does it make the noise if you rev it up in neutral? If so break out a stethoscope (aka long screw driver) and see if you can pin point it. I had main tensioners go bad that would make noise at random times.

Misspelling brought to you by Tapatalk
__________________
New Ride:
2004 Mystichrome Cobra-Accufab SBTB and plenum, Steeda 2.8" upper, Bassani X, Borla Stingers, Mcleod RXT, MGW shifter, Level 5 halfshafts, chrome FR500's, Stiffler's FIT system and DS safety loop, GT pumps, BA3000, tuned by owner
01yellerCobra is offline   Reply With Quote
Old 10-12-2017, 08:10 PM   #3
03Shadow Grey
Registered User
 
03Shadow Grey's Avatar
 
Join Date: Feb 2016
Location: Theodore Alabama
Posts: 243
Re: Lifter tapping noise !

No, no noise at neural. It has to be under a load , idling or coasting at constant speed wont make it happen but thanks for the suggestion.
03Shadow Grey is offline   Reply With Quote
Old 10-13-2017, 07:45 AM   #4
HAEG
Heppasketties
 
HAEG's Avatar
 
Join Date: Aug 2003
Location: Mercer County, NJ
Posts: 4,209
Re: Lifter tapping noise !

Just throwing this out there, is the A/C (defrost) on? I was thinking the tensioner was going bad on mine, but when I shut off the A/C the noise went away. Sounds like my compressor is going bad. Just a thought. Curious what the solution is for you....
__________________
M1R Member #1829
2011 Shelby GT-500 Grabber Blue
W/SVT Performance Package
Born on Friday, 6-25-2010
Purchased 8-19-2010

2003 Zinc Yellow Auto I/UP (its back)
Born on Thursday, 7/17/03
Purchased 8-18-2003 first owner
Sold 8-19-2010 bought GT500
Purchased again 3-3-2017 fifth owner
Purchased for my wife to drive (but she knows I love the car)
HAEG is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
(c) 2002-2013 Mach1Registry.com

<