2003-04 Mach 1 Registry Owners Club  

Best Mustang Parts

Go Back   2003-04 Mach 1 Registry Owners Club > "GO" Discussions > Fluid Systems (coolant, oil, fuel)

Reply
 
Thread Tools Display Modes
Old 08-06-2014, 09:09 AM   #26
noodle9400
Registered User
 
Join Date: May 2008
Location: Egg Harbor City, NJ
Posts: 188
Re: Fuel Pump

Has anyone ever had a fuel level indicator issue? My fuel level indicator is always malfunctioning and causing the check engine light to come on. Every time I fill my car up, my fuel gauge reads completely empty and engine light comes on. after about 50 or so miles, gauge works and so many miles following that the light goes off but eventually light comes back on.

I've never over filled my tank, never topped it off. I've been using chevron techron fuel additive/cleaner and still having the same issue. Any assistance would be greatly appreciated.
noodle9400 is offline   Reply With Quote
Old 08-06-2014, 10:49 AM   #27
Mach828
Dark Knight
 
Mach828's Avatar
 
Join Date: Nov 2009
Location: Albuquerque, NM
Posts: 5,759
Re: Fuel Pump

Quote:
Originally Posted by noodle9400 View Post
Has anyone ever had a fuel level indicator issue? My fuel level indicator is always malfunctioning and causing the check engine light to come on. Every time I fill my car up, my fuel gauge reads completely empty and engine light comes on. after about 50 or so miles, gauge works and so many miles following that the light goes off but eventually light comes back on.

I've never over filled my tank, never topped it off. I've been using chevron techron fuel additive/cleaner and still having the same issue. Any assistance would be greatly appreciated.
Pull the hat, and replace the fuel level sender. You might as well replace the pump while you are at it.

Ebay has inexpensive replacement options for the fuel level sender. The wiring is delicate, and its easy for it to get stuck too if its been pulled before.
__________________

Vortech V2 S-trim, E85, A2A Treadstone, Comp cams, built engine, full exhaust, built rear, built 4r70, more mods.

Tuned by me with SCT Advantage
Mach828 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:36 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
(c) 2002-2013 Mach1Registry.com

<