2003-04 Mach 1 Registry Owners Club  

Best Mustang Parts

Go Back   2003-04 Mach 1 Registry Owners Club > General Discussions > General Registry Discussion

General Registry Discussion Topics of Interest (Mach 1 Related or otherwise) for discussions that don't fit other forums.

Reply
 
Thread Tools Display Modes
Old 10-21-2017, 09:24 PM   #1
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
More issues

Having more issues with my mach, starting to feel like I bought a bad apple. New problem Iím having. This is an auto. When I press the gas lightly, with some force, or to the floor, the car shudders or stuttters like it canít breathe for a couple seconds and then clears up and accelerates. It can happen at any RPM in any gear. I have noticed an actual loss in power as well in general. Strangely enough this problem seems to occur any time I hit a bump or speed bump in the road but it may be a coincidence. Also this problem is very inconsistent, it will be there one day and gone the next. I have taken it to a shop and they found the air intake was loose, the MAF was dirty, and one 02 sensor was loose. All issues were fixed. However the problem is still there and I am at a loss. There seems to be no vacuum leaks and the exhaust is tight. Any opinions would be hugely appreciated. Thanks.
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs
slomach03 is offline   Reply With Quote
Old 10-21-2017, 11:20 PM   #2
DSG2003Mach1
700 HP Mach
 
DSG2003Mach1's Avatar
 
Join Date: Nov 2003
Location: Orlando, FL
Posts: 7,989
Re: More issues

When we’re the coils and plugs done last?
__________________
03 dsg mach1 - MPR built 9.5:1 motor, D1, cams, ported intake, full exhaust, magnum t56, built rear, E85 etc...

'12 F150 FX2 Supercrew with Ecoboost daily beater
DSG2003Mach1 is offline   Reply With Quote
Old 10-21-2017, 11:22 PM   #3
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
Re: More issues

Quote:
Originally Posted by DSG2003Mach1 View Post
When we’re the coils and plugs done last?
As far as I know, the coils have never been done. The plugs were changed to NKG TR copper in April.
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs

Last edited by slomach03; 10-21-2017 at 11:55 PM.
slomach03 is offline   Reply With Quote
Old 10-22-2017, 02:36 AM   #4
wutang61
CAT MASTA!
 
wutang61's Avatar
 
Join Date: Jun 2007
Location: Vero Beach, Florida
Posts: 3,412
Re: More issues

Sounds like a coil to me.
__________________
04' Torched 6-speed Build Date: 02/25/2004
Ported Eaton @7psi
Viper T-56
Built 8.8,4.10's

441/402
wutang61 is offline   Reply With Quote
Old 10-22-2017, 10:02 AM   #5
DSG2003Mach1
700 HP Mach
 
DSG2003Mach1's Avatar
 
Join Date: Nov 2003
Location: Orlando, FL
Posts: 7,989
Re: More issues

Coils can do weird ****, drone an f150 that only sputtered at half throttle, WOT was fine
__________________
03 dsg mach1 - MPR built 9.5:1 motor, D1, cams, ported intake, full exhaust, magnum t56, built rear, E85 etc...

'12 F150 FX2 Supercrew with Ecoboost daily beater
DSG2003Mach1 is offline   Reply With Quote
Old 10-22-2017, 11:00 AM   #6
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
Re: More issues

So replace the coils? Any brand suggestions? Thank you.
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs
slomach03 is offline   Reply With Quote
Old 10-22-2017, 11:23 AM   #7
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
Re: More issues

Would coils do the inconsistent stuff I described and is it possible for them to come loose over bumps? Seems like theyíre pretty well fastened in there.
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs
slomach03 is offline   Reply With Quote
Old 10-22-2017, 11:18 PM   #8
ab_mach1
Registered User
 
ab_mach1's Avatar
 
Join Date: Apr 2012
Location: Brownsburg, IN
Posts: 1,976
Quote:
Originally Posted by slomach03 View Post
Would coils do the inconsistent stuff I described and is it possible for them to come loose over bumps? Seems like they’re pretty well fastened in there.

They often have intermittent issues before they will make a CEL come on. My experience with them has been random misses at WOT and occasional “shark bite” like misses at every-day type driving.

What I do to help make sure it really is a COP going bad and not a bad connection is to use dielectric grease on the spark plug end of the boot. I’ve had to fix three of my COP wire harness clips too, but you’d see that problem upon visual inspection.
__________________
  • Azure Blue 04 Mach 1
  • SCT X3 with LaSota Racing tune
  • Borla Stingers w/JBA off road H pipe
  • MGW short shifter w/comfort handle
  • Eibach Sportlines w/Koni STR.T's and Maximum Motorsports CC plates
ab_mach1 is offline   Reply With Quote
Old 10-22-2017, 11:28 PM   #9
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
Re: More issues

Quote:
Originally Posted by ab_mach1 View Post
They often have intermittent issues before they will make a CEL come on. My experience with them has been random misses at WOT and occasional “shark bite” like misses at every-day type driving.

What I do to help make sure it really is a COP going bad and not a bad connection is to use dielectric grease on the spark plug end of the boot. I’ve had to fix three of my COP wire harness clips too, but you’d see that problem upon visual inspection.
Thanks Lee. Sounds like I do have a bad COP then. I ordered new ones from AM and I hope to report back in a week with the issue cleared up. Thanks.
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs
slomach03 is offline   Reply With Quote
Old 10-23-2017, 12:45 AM   #10
01yellerCobra
Registered User
 
Join Date: Jan 2013
Location: San Diego, CA
Posts: 1,063
Can you still get the replacement plugs from anyone? I have two that are broken.

Misspelling brought to you by Tapatalk
__________________
New Ride:
2004 Mystichrome Cobra-Accufab SBTB and plenum, Steeda 2.8" upper, Bassani X, Borla Stingers, Mcleod RXT, MGW shifter, Level 5 halfshafts, chrome FR500's, Stiffler's FIT system and DS safety loop, GT pumps, BA3000, tuned by owner
01yellerCobra is offline   Reply With Quote
Old 10-23-2017, 11:40 AM   #11
DSG2003Mach1
700 HP Mach
 
DSG2003Mach1's Avatar
 
Join Date: Nov 2003
Location: Orlando, FL
Posts: 7,989
Re: More issues

as mentioned when replacing the coils make sure the harness connectors are clipping in place/arent broken, those can cause intermittent issues. I had a bad one on my lightning that drove me nuts (of course it was on a 600mile trip without my handheld), ended up paying the dealer $95 for diagnosis and a zip tie since they didnt have the connector on hand.

im sure the replacements are out there. I believe Ford sells a harness repair kit that has the connectors and wires to splice in, if you buy that just de-pin the connectors and swap em. I wish I could remember where I bought just the clips for my lightning but that was like 8 years ago
__________________
03 dsg mach1 - MPR built 9.5:1 motor, D1, cams, ported intake, full exhaust, magnum t56, built rear, E85 etc...

'12 F150 FX2 Supercrew with Ecoboost daily beater
DSG2003Mach1 is offline   Reply With Quote
Old 10-23-2017, 06:45 PM   #12
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
Re: More issues

Quote:
Originally Posted by DSG2003Mach1 View Post
as mentioned when replacing the coils make sure the harness connectors are clipping in place/arent broken, those can cause intermittent issues. I had a bad one on my lightning that drove me nuts (of course it was on a 600mile trip without my handheld), ended up paying the dealer $95 for diagnosis and a zip tie since they didnt have the connector on hand.

im sure the replacements are out there. I believe Ford sells a harness repair kit that has the connectors and wires to splice in, if you buy that just de-pin the connectors and swap em. I wish I could remember where I bought just the clips for my lightning but that was like 8 years ago
Would you recommend adding zip ties to all of them for the heck of it?
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs
slomach03 is offline   Reply With Quote
Old 10-23-2017, 09:39 PM   #13
DSG2003Mach1
700 HP Mach
 
DSG2003Mach1's Avatar
 
Join Date: Nov 2003
Location: Orlando, FL
Posts: 7,989
Re: More issues

Not really, put the connector on and make sure it doesn’t just slide right back off.
__________________
03 dsg mach1 - MPR built 9.5:1 motor, D1, cams, ported intake, full exhaust, magnum t56, built rear, E85 etc...

'12 F150 FX2 Supercrew with Ecoboost daily beater
DSG2003Mach1 is offline   Reply With Quote
Old 10-23-2017, 10:13 PM   #14
ab_mach1
Registered User
 
ab_mach1's Avatar
 
Join Date: Apr 2012
Location: Brownsburg, IN
Posts: 1,976
I bought some COP connectors with pigtails from O’Reilly Auto last year and replaced the bad ones. Unfortunately, the ones I bought had slightly clips and would clip together great, but I couldn’t actually swap out the old clip for a new one. What I did worked well though, and I haven’t had any issues since.

Here’s the thread I made...
http://COP harness clip problems<br ...4&share_type=t
__________________
  • Azure Blue 04 Mach 1
  • SCT X3 with LaSota Racing tune
  • Borla Stingers w/JBA off road H pipe
  • MGW short shifter w/comfort handle
  • Eibach Sportlines w/Koni STR.T's and Maximum Motorsports CC plates
ab_mach1 is offline   Reply With Quote
Old 11-07-2017, 12:09 PM   #15
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
Re: More issues

So good news replaced the coils and all my issues have cleared up. Even feels like I gained a little power back I had lost. Thank you all for the great advice.

Im also experiencing a new issue. Iím getting a loud squeaking sound from my automatic shifter. It mainly happens in Drive but can really be in any gear. In my 05 manual 350z I had an identical noise. I took the shifter apart and found a brass washer that was loose. I removed it and the noise went away. Any suggestions on messing around with our auto shifters? Thanks.
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs
slomach03 is offline   Reply With Quote
Old 11-14-2017, 10:32 PM   #16
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
Re: More issues

Just to update everyone I found the squeaky noise my shaker tubing running to my air intake was loose and once I tightened it down it stopped the noise. Another thing. My Fing car starting doing that stuttering shuddering thing I first started this thread about again. After all the fixes I went thru it started again. So I went ahead and decided to check the coil covers and see if the plugs were somehow loose. This was right after the car had just been running. To my shock I found condensation and drops of water everywhere beneath the coil covers and on the cops and even down the rear most spark plug shaft. Every other time I had gone to trouble shoot the car I had opened up the coil covers after the car had been sitting some time. It was then I realized that everytime this issue had happened it had just rained. My drivers side coil cover has a leak. I took everything apart and cleaned the plugs and cops and went and drove it again. It ran like the monester I love. I went ahead and silicone sealed the **** out of the coil cover and the area where the cop wires come thru the firewall. Everything seems perfect now and I hope no more water can get in. If anyone has any other suggestions for waterproofing I would really appreciate it. Thanks all.
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs
slomach03 is offline   Reply With Quote
Old 11-14-2017, 11:38 PM   #17
ab_mach1
Registered User
 
ab_mach1's Avatar
 
Join Date: Apr 2012
Location: Brownsburg, IN
Posts: 1,976
More issues

Glad you found out about the leaky coil cover. Is the gasket still in good shape? They still sell replacement gaskets for those. I bought a set to put on my custom could covers I bought about two years back.

https://rover.ebay.com/rover/0/0/0?m...2F232549828582
__________________
  • Azure Blue 04 Mach 1
  • SCT X3 with LaSota Racing tune
  • Borla Stingers w/JBA off road H pipe
  • MGW short shifter w/comfort handle
  • Eibach Sportlines w/Koni STR.T's and Maximum Motorsports CC plates
ab_mach1 is offline   Reply With Quote
Old 11-15-2017, 12:05 AM   #18
slomach03
Registered User
 
slomach03's Avatar
 
Join Date: Nov 2016
Location: Central California
Posts: 192
Re: More issues

Quote:
Originally Posted by ab_mach1 View Post
Glad you found out about the leaky coil cover. Is the gasket still in good shape? They still sell replacement gaskets for those. I bought a set to put on my custom could covers I bought about two years back.

https://rover.ebay.com/rover/0/0/0?m...2F232549828582
Honestly the gasket seems fine it was leaking like a sponge right where the cop wiring starts closest to the firewall. Iím just surprised the water didnít do any more damage. As long as the silicone holds up I should be fine but if not Iíll try that link you sent for the gasket. Thanks
__________________
2003 TORCH RED Mach 1 Auto
SLP Loudmouth 1
Mac O/R ProChamber
ICT Billet 1/2in Spacer
JLT Ram Air Intake
FRPP 4.10 Gears
FRPP Aluminum DriveShaft
SCT REV X Tuner
Black 17X9 1995 Cobra Rs
slomach03 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:35 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
(c) 2002-2013 Mach1Registry.com

<